Reply to this topicStart new topicStart Poll

> DirectX Surface Unavailable
Guest
Posted: Jun 12 2006, 07:30 PM
Quote Post


Unregistered









In my experience, this is a memory/graphics card problem. By decreasing univrse sizes, # AIS, etc. I have been able to work around this problem.

But on my friend's older computer we get errors when he starts trying to create mega-maps with too many stars, or if he gets a larger map to run then it starts crapping out after a while when the universe starts filling up.

The solution is to get a better comp or use smaller universes.
Top
Grimbear
Posted: Jun 20 2006, 11:30 PM
Quote Post


Unregistered









Pretty much everyone has gotten the DirectX error at some point, I'm sure! As posted previously, using a smaller galaxy helps (especially if you don't have enough available PHYSICAL ram; the game doesn't seem to utilize virtual ram well; could just be my (3) computers, though. (I'm set up as a network, so me & friends can play on-line together, all at my place.) I also had some issues/bugs with my Router(Nat) and "GhostSurF", until I cleaned up some of the resident "junk" files on my computer and made more PHYSICAL ram available. Remember, EVERYTHING on your computer has SOME effect on available, physical ram size. To say it another way, 3 kilobytes alone aren't a lot; 3 kilobytes times 30 or forty un-used files adds up. Try deleting or saving the files you don't use, to 'floppies' or tape back-ups and that should really help, especially if you (only?) have 512 megs of ram. Your "Actual AVAILABLE ram" would be closer to 256 or so; check it out by viewing System Resources (Hunt for it until you find it; that's how I did it. Sometimes you'll learn faster and better if you have to work a little biy for the answers). Yes, it will say that you have lots of virtual ram; but the game DOES require a certain level of physical ram for EFFECTIVE game play. Hope this helps.
Top
porcelain808
Posted: Jul 20 2007, 05:29 AM
Quote Post


Recruit
*

Group: Members
Posts: 1
Member No.: 1,969
Joined: 20-July 07



I believe I'm onto the trail of the problem, but I haven't had enough recurrences to claim a cure. For my computer, I believe the problem resides with the saved game files (and/or autosave files).

My main problem with the directx surface dealt with saved games. I had other problems, too, like the game shutting down in the middle of play and then working fine the next time I started up and loaded my saved game. I didn't mind that so much, but when the problem crept into my load/save game abilities, I got frustrated. Specifically, I would get the 'ol directx surface problem as soon as I clicked on 'load saved game' after the intro screens. I tried the aforementioned alt-tab trick and that didn't work - every time I tried to load a saved game or save a new game that I had already started, I would get the directx problem.

MOO3 creates a saved game folder. Make a copy of your last saved game on your Desktop or somewhere else. Delete all saved games, including the autosave file, in this folder. Then re-start the game and try to load a saved game (if this has been your problem). If MOO3 proceeds successfully to the next screen, then quit the game and transfer a copy of your last saved game to the saved game folder. I did this, and it worked for me. Afterwards, I had only one recurrence of the directx problem, and that didn't prevent me from re-starting the game and loading my newest saved game (or autosave).

My computer: Dell laptop, 1.6 GHz Intel Duo Core processor, 1 GB RAM, 120 GB HD, Intel graphics (200 MB effective, but none dedicated), Windows Vista, minimal additional software (no MS Office). For what it's worth.
PMEmail Poster
Top
pedxing
Posted: Jul 20 2007, 06:02 AM
Quote Post


Veteran
****

Group: Supermoderator
Posts: 651
Member No.: 652
Joined: 24-January 06



the DXSU error (DirectX Surface Unavailable) is the generic error that Moo3 gives whenever anything goes wrong.

there are dozens of possible causes.

usually it is conflicting mods, but it can also mean file corruption, or even that you have named a planet something that the game doesn't like (never, ever use a hyphen in your planet names!)

there's no way to tell, except by a process of elimination, figuring out all the things it can't be, until you (hopefully) find out what is causing it.


--------------------
Fish Friend? Lizard Lover? Human Hater? check it here: FFLLHH
fresh install? looking for the 1.2.5 patch? or the install verifier?
MUU:BaA Release Candidate, aka "Chocolate" is now available here !
Nice galaxy ya got here... sure would be a shame if anything happend to it...
PMEmail Poster
Top
0 User(s) are reading this topic (0 Guests and 0 Anonymous Users)
0 Members:
« Next Oldest | Support Forum | Next Newest »

Reply to this topicStart new topicStart Poll